Using USB sound card with amarok


#1

Sometimes it is hard to use external usb card with amarok if it is not selected as default.

In order to configure amarok to use usb sound card, you must learn the name of your usb sound card first with:

$ cat /proc/asound/cards
0 [Intel          ]: HDA-Intel - HDA Intel
1 [U0x41e0x30d3   ]: USB-Audio - USB Device 0x41e:0x30d3

After that, just open the amarok settings window -> engine settings and checked output that if alsa is selected, if not select alsa first.

After that enter your soundcard’s name with a prefix of plughw: as below:

plughw:U0x41e0x30d3

save the settings and play another file, it should work.