Ruby irb command history problem

Today I just installed the ruby-2.3 packages from standard Debian repositories rather than using rvm or rbenv.

Soon after I realize that command history not working in irb shells.

Here is a quick solution:

Create .irbrc file in your home directory and paste following line into it:

IRB.conf[:SAVE_HISTORY] = 1000

In this example we’re saying that most recent 1000 lines of command history must be saved.

And there are also lots of other options which you can find the details here: