Pppd connection loss then reconnect


#1

Hi;

I make pppd connection with configurations which are at the bottom. But many times later, my connection loses then can’t reconnect to internet. What is the stable configuration for pppd?

ttyACM0 460800
user internet
password internet
connect 'chat -f /etc/ppp/chat/gprs_chat -e'
novj
asyncmap 0
defaultroute
usepeerdns
debug
kdebug 7
nodetach
noipdefault
lock
modem
lcp-echo-interval 0
lcp-echo-failure 4
lcp-max-configure 60
lcp-restart 2
idle 600
noipx
logfile /home/logppp.txt

#2

Could you send pppd logfile output?


#3

logfile and pppd always on script : https://drive.google.com/folderview?id=0B3FMvhilYdQFWjFHWnZXMG9uMms&usp=sharing


#4

There is no exact hint about the problem in the log file.

You can check LCP configuration options starts with lcp- (see: man pppd)

If you set lcp-echo-interval to 30 seconds and LCP-Echo requests failed at number of lcp-echo-failure, pppd will exit.

It is not clear that how pppd behaves when lcp-echo-interval = 0 like your setup. So, it is good to use a reasonable value here.

You also have idle = 600 parameter, so if no IP packets seen by pppd for last 600 seconds, it will be stopped.


#5

My client is connecting to webservice every minute. This configuration is good for me ?

ttyACM0 460800
user internet
password internet
connect 'chat -f /etc/ppp/chat/gprs_chat -e’
novj
asyncmap 0
defaultroute
usepeerdns
debug
kdebug 7
nodetach
noipdefault
modem
lcp-echo-interval 10
lcp-echo-failure 12
lcp-max-configure 60
lcp-restart 120
idle 600
noipx
logfile /home/logppp.txt


#6

You’re sending IP data on every 60 seconds. It will be good to detect GPRS session lost errors, so you can use

lcp-echo-interval 30
lcp-echo-failure 2

With above configuration, pppd will be terminated if it can’t get any replies for two consecutive LCP Echo Request.


#7

Hi;

I found problem, it is about usb driver. When repower modem, it works normallya again. Logs are at link. Could you analyse it ?

https://drive.google.com/folderview?id=0B3FMvhilYdQFYVgtcnRGNUIzZG8&usp=sharing

is it about this parameter?

dwc_otg.speed=1 //forces usb full-speed (12 Mbit/s), otherwise the usb is running at hi-speed (480 Mbit/s).

#8

It is not easy to find root cause of the problem.

All of the USB 3G modems I used has very buggy drivers. None of them designed for 7x24 non-interactive work, it basically targets desktop user who can un-plug and plug the device again if it doesn’t work.

It is also possible to have usb problems in your embedded board but I can easily say that main problem is the 3G usb modem itself according to my previous experience.

So, good luck :smile:


#9

:confused: I want to cry , insaallah I will find solution, If I find, I will share it. Thanks for your help.