How to solve No EFI partition was found error


Today I tried to install Debian Jessie on a notebook which has an UEFI BIOS and secure boot support.

I’ve created required disk partitions manually but when I try to continue on installation process, it gives me following error:

No EFI partition was found

So, I’ve created another FAT32 partition and select mount point as /boot/efi but it also doesn’t work.

How can I solve this problem?


If you’re choosing manuel partitioning option at Debian installation process on a system which booted in UEFI mode, you have to create an EFI System Partition (ESP).

ESP partition will be formatted with FAT filesystem as your case. But, you need to set partition type as:

  • If you’re using GPT partitioning, ESP partition GUID must be: C12A7328-F81F-11D2-BA4B-00A0C93EC93B
  • If you’re using legacy DOS partitioning, partition type code must be: 0xEF

You should create a new partition manually about 250MB in size. After that, in How to use this partition menu, don’t select FAT32 as filesystem, select Use as: EFI System Partition

Now you will see ESP flags on the partition list. There is one more steps: you have to toggle bootable option on this newly created ESP partition.

After all of the above steps completed, you can continue to install your Debian system.


I met the same problem when I install debian using manually disk partition.I fixed it by erasing data of the / directory