How can I disable snmpd ia_addr insert messages?


#1

Hi,

We have Debian and Ubuntu servers which runs snmpd service. We are getting following message every 30 seconds in /var/log/syslog:

error on subcontainer 'ia_addr' insert (-1)

How can we solve this problem?


#2

This problem related with the log level start options of snmpd service.

On Debian based systems, start options configured through /etc/default/snmpd file and it has following default settings:

SNMPDOPTS='-Lsd -Lf /dev/null -u snmp -g snmp -I -smux,mteTrigger,mteTriggerConf -p /run/snmpd.pid'

With the above configuration, snmpd service sends all the logs including LOG_DEBUG to syslog.

You need to change minimum loglevel parameter as LOG_INFO to fix this problem.

To do this, change -Lsd parts of the SNMPDOPTS as -LS6d:

$ sudo sed -i "s|-Lsd|-LS6d|" /etc/default/snmpd

If you want to change loglevel as LOG_ERROR and above, you can use -LS3d.

Snmpd’s startup logging parameters a little complex. You may need to look at LOGGING OPTIONS section of man snmpcmd.


#3

After systemd migration starting from Debian 9 Stretch, you need to change /lib/systemd/system/snmpd.service file, not /etc/default/snmpd file:

$ sudo sed -i "s|-Lsd|-LS6d|" /lib/systemd/system/snmpd.service
$ sudo systemctl daemon-reload
$ sudo service snmpd restart