Fixing slow nfs mount problem


#1

If you have a delay about 10-15 seconds when mounting shared NFS folders, check logfiles (/var/log/syslog, /var/log/messages) for a log like this:

RPC: AUTH_GSS upcall timed out

If you can see similar logs, your nfs mounts delayed by the Kerberos authentication on server side. If your NFS server in a network which needs Kerberos authentication, you have to set NEED_GSSD=yes in /etc/default/nfs-common file. After reboot, mount delays will be disappear.

But, most of the time you’re not in a Kerberos enabled network or you don’t need Kerberos authentication mechanism in your NFS server. If so, you have to blacklist rpcsec_gss_krb5 Linux kernel module. To do this create a file named /etc/modprobe.d/blacklist-nfs-gss.conf and add following line into that file:

blacklist rpcsec_gss_krb5

After reboot, you can mount without any delays.