Bluetooth service doesn't start automatically on Debian Jessie


#1

I’m using bluetooth keyboard and mouse with Debian Jessie distribution. Everything works well until today but now bluetooth service doesn’t start automatically. When I looked at the bluetooth status on the gnome-control-center it shows that Bluetooth is ON and visible as Foobar

But my hostname is not Foobar. When I check the bluetooth status with:

$ sudo systemctl status bluetooth

it shows that bluetooth service is not running.

If I try to start it manually with:

$ sudo systemctl start bluetooth

everything start to work properly and visible under my hostname.

I couldn’t find any working solution, removing all of the my ~/.gnome settings also doesn’t make any sense.


#2

I have a similar problem on last week.

In my case, I see that it is related with the newly installed teamviewer package.

I used teamviewer version 10.0.37742 without any problems. But, when I upgrade it to version 10.0.41499, bluetooth service problems started.

If you installed teamviewer recently, most probably you have the same problem. To solve this, uninstall the teamviewer package and try to use older versions, at least you must not use the version 10.0.41499.

It can be a problem with teamviewer’s systemd settings, you can also try newer packages, it should be fixed by the teamviewer company soon.


#3

I’ve checked with current teamviewer version 12.0.71510 and confirm that problem still exists.

If you don’t have an option to remove new version and use old 10.X versions, you can use following workaround:

# disable teamviewerd service
$ sudo systemctl disable teamviewerd 

and reboot the system. On next boot, bluethooth service will be run properly and you will be able to use bluetooth keyboard on the gdm session.

As a downside of this, when you want to start teamviewer application, you need to manually start teamviewerd service before:

$ sudo service teamviewerd start

#4

I couldn’t reproduce the problem on version 13.0.6634. So, you don’t need to disable teamviewer service anymore.